HermitCollective.nix/system/nixos.nix

39 lines
776 B
Nix

{
boot = {
loader = {
efi.canTouchEfiVariables = true;
systemd-boot = {
enable = true;
editor = false;
};
};
};
nix = {
settings = {
# Enable flakes and new 'nix' command
experimental-features = "nix-command flakes";
# Deduplicate and optimize nix store
auto-optimise-store = true;
};
};
nixpkgs.config = {
allowUnfree = true;
};
networking = {
hostName = "HermitCollective";
domain = "hermitcollective.net";
firewall.allowedTCPPorts = [ 22 80 443 8080 8181 1935 6667 ];
};
security.acme = {
acceptTerms = true;
defaults.email = "hertog@fsfe.org";
};
# Hertog if you are wanting to change this don't oke? thanks
system.stateVersion = "23.05";
}