HermitCollective.nix/services/uptime-kuma.nix

25 lines
585 B
Nix

{
services.uptime-kuma = {
enable = true;
settings = {
PORT = "4000";
};
};
services.nginx.virtualHosts."status.hermitcollective.net" = {
forceSSL = true;
enableACME = true;
locations."/" = {
proxyPass = "http://localhost:4000";
proxyWebsockets = true; # needed if you need to use WebSocket
extraConfig =
# required when the target is also TLS server with multiple hosts
"proxy_ssl_server_name on;" +
# required when the server wants to use HTTP Authentication
"proxy_pass_header Authorization;"
;
};
};
}