HermitCollective.nix/services/owncast.nix

24 lines
635 B
Nix

{
services.owncast = {
enable = true;
port = 8181;
openFirewall = true;
};
# Homepage
services.nginx.virtualHosts."live.hermitcollective.net" = {
forceSSL = true;
enableACME = true;
locations."/" = {
proxyPass = "http://localhost:8181";
proxyWebsockets = true; # needed if you need to use WebSocket
extraConfig =
# required when the target is also TLS server with multiple hosts
"proxy_ssl_server_name on;" +
# required when the server wants to use HTTP Authentication
"proxy_pass_header Authorization;"
;
};
};
}