HermitCollective.nix/services/akkoma-media.nix

18 lines
539 B
Nix

{
# Reqeusts SSL and adds the site to nginx
services.nginx.virtualHosts."media.nederland.gay" = {
forceSSL = true;
enableACME = true;
locations."/" = {
proxyPass = "http://192.168.178.243/";
proxyWebsockets = true; # needed if you need to use WebSocket
extraConfig =
# required when the target is also TLS server with multiple hosts
"proxy_ssl_server_name on;" +
# required when the server wants to use HTTP Authentication
"proxy_pass_header Authorization;"
;
};
};
}