Godot-Rust_template/nix/shell.nix

24 lines
710 B
Nix

{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
# The Nix packages provided in the environment
packages = (with pkgs; [
rust-bin.stable."1.70.0".default
# Fluff
cargo-mommy
onefetch
# Godot
godot_4
# Rust
rustup
rustToolchain
]) ++ pkgs.lib.optionals pkgs.stdenv.isDarwin (with pkgs; [ libiconv ]);
shellHook = ''
# Aliases and other fluff/ease of use
alias edit="godot4 godot/project.godot -e"
alias run="godot4 godot/Scenes/sample_scene.tscn" # Change this with the main scene of your project
onefetch
echo "Welcome to nix-hell uh nix-shell!"
'';
}